ed

Classic UNIX line editor
https://www.gnu.org/software/ed/ed.html

Current versions
1.14.2

ed requires the following formula to be installed:
lzip 1.19 LZMA-based compression program similar to gzip or bzip2

Recent formula history

ilovezfs Use “squiggly” heredocs.
ilovezfs ed: swap GNU url and mirror.
Mike McQuaid ed: import homebrew/dupes into core.

Formula code at GitHub